<!doctype html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <title>Hundreds mourn death of passionate Black Lives Matter activist Travis Nagdy - LEO Weekly</title>
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta name="google-site-verification" content="4yw5m3aUj2XVqqWaiHLKYZUdpAhZOqUkOzQcKp4xnc8" />
    <meta property="fb:app_id" content="334476176751082" />

    <link rel="shortcut icon" href="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/themes/leo/assets/img/favicon.ico">
    <link rel="alternate" type="application/rss+xml" title="LEO Weekly Feed" href="https://www.leoweekly.com/feed/">
    <script type="text/javascript">
        WebFontConfig = {
            google: { families: [ 'Open+Sans:400italic,700italic,400,700:latin' ] }
        };
        (function() {
            var wf = document.createElement('script');
            wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
            '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
            wf.type = 'text/javascript';
            wf.async = 'true';
            var s = document.getElementsByTagName('script')[0];
            s.parentNode.insertBefore(wf, s);
        })();
    </script>
    <script src="https://use.typekit.net/aex1xbf.js"></script>
    <script>try{Typekit.load({ async: true });}catch(e){}</script>

    <!-- Google Tag Manager -->
    <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-MBKVHB2');</script>
    <!-- End Google Tag Manager -->

        
<!-- This site is optimized with the Yoast SEO plugin v4.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Family, friends and fellow protesters gathered Monday to remember Hamza “Travis” Nagdy, 21, who was shot and killed on Crittenden Drive."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.leoweekly.com/2020/11/hundreds-mourn-death-passionate-black-lives-matter-activist-travis-nagdy/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Hundreds mourn death of passionate Black Lives Matter activist Travis Nagdy - LEO Weekly" />
<meta property="og:description" content="Family, friends and fellow protesters gathered Monday to remember Hamza “Travis” Nagdy, 21, who was shot and killed on Crittenden Drive." />
<meta property="og:url" content="https://www.leoweekly.com/2020/11/hundreds-mourn-death-passionate-black-lives-matter-activist-travis-nagdy/" />
<meta property="og:site_name" content="LEO Weekly" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2020-11-24T14:31:09-05:00" />
<meta property="article:modified_time" content="2020-11-24T14:52:20-05:00" />
<meta property="og:updated_time" content="2020-11-24T14:52:20-05:00" />
<meta property="og:image" content="https://www.leoweekly.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks32.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Family, friends and fellow protesters gathered Monday to remember Hamza “Travis” Nagdy, 21, who was shot and killed on Crittenden Drive." />
<meta name="twitter:title" content="Hundreds mourn death of passionate Black Lives Matter activist Travis Nagdy - LEO Weekly" />
<meta name="twitter:site" content="@leoweekly" />
<meta name="twitter:image" content="https://www.leoweekly.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks32.jpg" />
<meta name="twitter:creator" content="@leoweekly" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.leoweekly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.16"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='leo_css-css'  href='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/themes/leo/assets/css/main.min.css?f9d1e17ad7fc19bee30be2a26755b302' type='text/css' media='all' />
<script type='text/javascript' src='//ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js'></script>
<link rel='https://api.w.org/' href='https://www.leoweekly.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.leoweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.leoweekly.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.leoweekly.com/?p=76369' />
<link rel="alternate" type="application/json+oembed" href="https://www.leoweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.leoweekly.com%2F2020%2F11%2Fhundreds-mourn-death-passionate-black-lives-matter-activist-travis-nagdy%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.leoweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.leoweekly.com%2F2020%2F11%2Fhundreds-mourn-death-passionate-black-lives-matter-activist-travis-nagdy%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.13.2 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script>window.jQuery || document.write('<script src="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/themes/leo/assets/vendor/jquery/dist/jquery.min.js?1.11.1"><\/script>')</script>

<!-- Facebook Pixel Code -->
<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>
<!-- End Facebook Pixel Code -->
<script type='text/javascript'>
  fbq('init', '1166499293750190', {}, {
    "agent": "wordpress-4.9.16-2.0.2"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>
<!-- Facebook Pixel Code -->
<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=1166499293750190&ev=PageView&noscript=1" />
</noscript>
<!-- End Facebook Pixel Code -->
</head>
<body class="post-template-default single single-post postid-76369 single-format-standard hundreds-mourn-death-passionate-black-lives-matter-activist-travis-nagdy sidebar-primary">

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MBKVHB2"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=334476176751082&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>



<header class="banner navbar navbar-default navbar-static-top" role="banner">
    <div class="brand container">
        <div class="navbar-header">
            <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".navbar-collapse">
                <span class="sr-only">Toggle navigation</span>
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
            </button>
            <a class="navbar-brand" href="https://www.leoweekly.com/"><img src="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/themes/leo/assets/img/logo.png" alt="LEO Weekly"></a>
        </div>
    </div>
    <div class="container">
                            <div class="ad ad-banner" data-ad-group-id="1" data-ajax-url="https://www.leoweekly.com/wp-admin/admin-ajax.php"></div>
            </div>
    <nav class="collapse navbar-collapse" role="navigation">
        <div class="main-nav">
            <div class="container">
                <ul id="menu-primary-navigation" class="nav navbar-nav"><li class="menu-arts"><a href="https://www.leoweekly.com/category/arts/">Arts</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="https://www.leoweekly.com/2020/11/your-friendly-neighborhood-comic-book-reviews-2/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/punchline1-666x1024.jpg"></div><header><h4>Comic Book Reviews: ‘Punchline Special’ &#038; ‘Your Ride’s Here’</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/11/glossary-drama-layers/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/AE_Book_IanStansel-e1605721898199-300x192.jpg"></div><header><h4>‘Glossary’: drama, layers</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/11/your-friendly-neighborhood-comic-book-reviews/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/TheAutumnal1-197x300.jpg"></div><header><h4>Comic Book Reviews: ‘Review of The Autumnal’ &#038; ‘An Unkindness of Ravens’</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/11/louisville-anthology-timely-angry/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/AE_Book_LouisvilleAnthology-203x300.jpg"></div><header><h4>‘Louisville Anthology’ timely, angry</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/10/think-know-macbeth-drive-version-startles-audience/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/10/AE_Theater_ParklingLotMacbeth-300x200.jpg"></div><header><h4>Think you know ‘Macbeth’? Drive-in version startles audience</h4></header></a></div></div></div></div></div></li>
<li class="menu-music"><a href="https://www.leoweekly.com/category/music/">Music</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="https://www.leoweekly.com/2020/11/music-instrument-shops-adapt-to-survive-boredom-stimulus-checks-and-technology-helped/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/Music_MusicShop-1024x683.jpg"></div><header><h4>Music instrument shops adapt to survive: Boredom, stimulus checks and technology helped</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/11/winter-sets-local-music-venues-fight-stay-open-safety-measures-help-federal-relief-needed/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/Music_Venues-e1605110458925-300x168.jpg"></div><header><h4>As winter sets in, local music venues fight to stay open</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/11/rmllw2llz-gets-personal-on-concerto-no-9-movement-ii-v/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/Music_Rmllw2llz-300x200.jpg"></div><header><h4>Rmllw2llz gets personal on Concerto No.9 Movement II.V</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/10/7-recently-released-songs-from-local-artists/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/10/Music_List2-300x157.jpg"></div><header><h4>7 recently-released songs from local artists</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/plugged-in/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2019/08/Music_PluggedIn_2_90035516-300x157.jpg"></div><header><h4>Plugged-in</h4></header></a></div></div></div></div></div></li>
<li class="current-post-ancestor active current-post-parent menu-news"><a href="https://www.leoweekly.com/category/news/">News</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="https://www.leoweekly.com/2020/11/hundreds-mourn-death-passionate-black-lives-matter-activist-travis-nagdy/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks32-1024x683.jpg"></div><header><h4>Hundreds mourn death of passionate Black Lives Matter activist Travis Nagdy</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/11/black-owned-businesses-support-theyre-supporting-others/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/LEO_KH_GardenGirlPicks6-300x200.jpg"></div><header><h4>Black-owned businesses: Why you should support them, how they’re supporting others</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/11/kdp-elects-first-black-chair-new-ideas-enough/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/News_Dems-300x240.jpg"></div><header><h4>KDP elects first Black chair: with new ideas, is it enough?</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/11/thorns-roses-worst-best-absurd-11-18/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2019/12/News_ThornsRoses_A-2-300x157.jpg"></div><header><h4>Thorns &#038; Roses: The Worst, Best And Most Absurd (11/18)</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/11/dear-black-people-you-will-not-good-person-your-way-out-of-racism/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/06/SP_Speed_HannahDrake-1024x537-300x157.jpg"></div><header><h4>Dear Black People, You Will Not ‘Good Person’ Your Way Out Of Racism</h4></header></a></div></div></div></div></div></li>
<li class="menu-food-drink"><a href="https://www.leoweekly.com/category/food-drink/">Food &#038; Drink</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="https://www.leoweekly.com/2020/11/bar-vetti-serves-italian-veggie-feast/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2019/04/VEGout-1024x609-1.jpg"></div><header><h4>bar Vetti serves Italian veggie feast</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/11/emmy-squared-brings-detroit-pizza-brooklyn/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/FoodDrink_R_EmmySq_vodkapizza_box-e1605717090101-300x199.jpg"></div><header><h4>Emmy Squared brings Detroit pizza from Brooklyn</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/11/eat-out-local/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/Feature_Dining_Quarantine_Ramsis-300x200.jpg"></div><header><h4>Eat (Out) Local: Nine Of Our Favorites</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/11/hillcrest-tavern-offers-pure-comfort/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/Hillcrest_pattymelt-300x225.jpg"></div><header><h4>Hillcrest Tavern offers pure comfort</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/10/big-mommas-soul-food-kitchen-standout/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/10/FoodDrink_R_BigMomma_meatloaf-300x162.jpg"></div><header><h4>Big Momma’s Soul Food Kitchen a standout</h4></header></a></div></div></div></div></div></li>
<li class="menu-staffpicks"><a href="https://www.leoweekly.com/category/staffpicks/">Staffpicks</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="https://www.leoweekly.com/event/winter-illuminations/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/SP_WinterIlluminations-1024x685.jpg"></div><header><h4>Winter Illuminations</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/event/thanksgiving-day-run/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/Running-Turkey-01-300x245.jpg"></div><header><h4>Thanksgiving Day Run</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/event/creating-change-arts-kara-walker/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/SP_KarenWalker-300x223.jpg"></div><header><h4>‘Creating Change Through The Arts’  By Kara Walker</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/event/louisville-ballet-kentucky-volume-1/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/SP_Ballet-300x159.png"></div><header><h4>Louisville Ballet: ‘Kentucky! Volume 1’</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/event/reel-latin-american-film-festival-guiedanis-navel/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/11/SP_Film-300x150.jpg"></div><header><h4>Reel Latin American Film Festival:  ’Guie’Dani’s Navel’</h4></header></a></div></div></div></div></div></li>
<li class="menu-beer"><a href="https://www.leoweekly.com/beer-guide/">Beer</a></li>
<li class="menu-promos"><a href="https://www.leoweekly.com/promos/">Promos</a></li>
<li class="mobile-only menu-plugged-in"><a href="https://www.leoweekly.com/plugged-in/">Plugged-in</a></li>
</ul>            </div>
        </div>
        <div class="secondary-nav">
            <div class="container">
                <ul id="menu-secondary-navigation" class="nav navbar-nav nav-secondary"><li class="highlight-green menu-margaritas"><a href="https://www.leoweekly.com/margaritas-in-the-ville/">Margaritas</a></li>
<li class="highlight-teal menu-readers-choice"><a href="https://www.leoweekly.com/readers-choice/">Readers&#8217; Choice</a></li>
<li class="highlight-blue menu-literary-leo"><a href="/literary-leo-2019">Literary LEO</a></li>
<li class="menu-shop"><a href="http://shop.leoweekly.com/">Shop</a></li>
<li class="highlight-red-orange menu-red-pin-tix"><a target="_blank" href="http://LouisvilleTickets.com">Red Pin Tix</a></li>
<li class="search"><a href="/search/" class="btn-search-toggle"><i class="fa fa-search"></i></a></li></ul>                <div class="searchform"><form role="search" method="get" class="search-form form-inline" action="https://www.leoweekly.com/">
  <label class="sr-only">Search for:</label>
  <div class="input-group">
    <input type="search" value="" name="s" class="search-field form-control" placeholder="Search LEO Weekly" required>
    <span class="input-group-btn">
      <button type="submit" class="search-submit btn btn-default">Search</button>
    </span>
  </div>
</form>
</div>
            </div>
        </div>
    </nav>
</header>

<div class="wrap container" role="document">
    <div class="content row">
                <main class="main" role="main">
                    <article class="post-76369 post type-post status-publish format-standard has-post-thumbnail hentry category-news">
            <div class="featured-image clearfix">
        <a href="https://www.leoweekly.com/2020/11/hundreds-mourn-death-passionate-black-lives-matter-activist-travis-nagdy/"><img width="1024" height="683" src="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks32-1024x683.jpg" class="attachment-large size-large wp-post-image" alt="" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks32-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks32-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks32-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks32.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /></a>
        <span class="image-caption">Jefferson Square Park was filled with friends, family and fellow protesters on Monday night as they came together to mourn Travis Nagdy.</span>    </div>
        <header>
            <div class="category"><a href="https://www.leoweekly.com/category/news/" rel="category tag">News</a></div>
            <h1 class="entry-title">Hundreds mourn death of passionate Black Lives Matter activist Travis Nagdy</h1>
                        <div class="entry-meta pulled">
            <time class="updated" datetime="2020-11-24T14:31:09+00:00">
            <span class="month">Nov</span>
            <span class="day">24</span>
            <span class="year">2020</span>
        </time>
        <div class="sharing">
        <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-508fc29018b39fef" async="async"></script>
        <!-- Go to www.addthis.com/dashboard to customize your tools -->
        <div class="addthis_sharing_toolbox"></div>
    </div>
</div>
            <p class="byline author vcard">
                By                                                                                <a href="mailto:leo@leoweekly.com" rel="author" class="fn sly">Kathryn Harrington</a>                                                </p>
        </header>
        <div class="entry-content">

            <p>Family, friends and fellow protesters gathered Monday to remember Hamza “Travis” Nagdy, 21, who was shot and killed on Crittenden Drive early Monday morning. The death of the prominent, energetic organizer and protest leader has devastated protesters who have been fighting for justice for Breonna Taylor since May 28.</p>
<figure id="attachment_76396" style="width: 477px" class="wp-caption alignright"><img class=" wp-image-76396" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-2-2.jpg" alt="" width="477" height="522" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-2-2.jpg 641w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-2-2-274x300.jpg 274w" sizes="(max-width: 477px) 100vw, 477px" /><figcaption class="wp-caption-text">Hamza ‘Travis’ Nagdy, a beloved activist, was shot and killed Monday. He was 21.</figcaption></figure>
<p>At 3 p.m. Monday, the group of mourners gathered in the 2100 block of Crittenden Drive where Nagdy was shot. There, they placed flowers, signs and photos to honor him. A caravan then went downtown to Jefferson Square Park where hundreds gathered for a candlelight vigil.<span class="Apple-converted-space"> </span></p>
<p>Many of his friends and family members spoke to the crowd about Nagdy, emphasizing his passion and charisma in the fight against racial inequality and police violence.</p><div class="inline-ad"><h6>Advertisement</h6><div class="ad" data-ad-group-id="4" data-ajax-url="https://www.leoweekly.com/wp-admin/admin-ajax.php"></div></div>
<p>Police had not identified a suspect or suspects in Nagdy’s death, The Courier Journal reported.</p>
<p>His sister set up a <a href="https://www.gofundme.com/f/funeral-costs-for-blm-activist?utm_source=customer&amp;utm_campaign=p_cp+share-sheet&amp;utm_medium=copy_link_all">GoFundMe</a> page to pay for a funeral: “My brother was murdered. He was only 21 years old. He was an avid activist for Black Lives Matter. He was an inspirational leader. We are poor and can not afford any money at all for his funeral. Our mother lives on disability and I just lost my job due to covid. Please. Anything helps even a share.”</p>
<figure id="attachment_76370" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76370" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks1-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks1-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks1-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks1-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks1.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Friends, family and fellow protesters gathered in the 2100 block of Crittenden Drive where Travis Nagdy was killed on Monday.</figcaption></figure>
<figure id="attachment_76371" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76371" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks3-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks3-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks3-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks3-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks3.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Protesters hugged each other while they gathered on Crittenden Drive to mourn the loss of Travis Nagdy.</figcaption></figure>
<figure id="attachment_76382" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76382" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks24-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks24-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks24-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks24-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks24.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Nagdy’s mother Christina Muimneach was joined by her son’s friends and mourners on Crittenden Drive where he was fatally shot early Monday morning.</figcaption></figure>
<figure id="attachment_76383" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76383" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks25-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks25-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks25-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks25-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks25.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Friends of Nagdy surrounded his mother Christina Muimneach on Crittenden Drive where he was fatally shot early Monday morning.</figcaption></figure>
<figure id="attachment_76372" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76372" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks4-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks4-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks4-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks4-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks4.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Posters and photos were placed in the street on Crittenden Drive where social justice activist Travis Nagdy died from a gunshot wound on Monday.</figcaption></figure>
<figure id="attachment_76373" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76373" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks5-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks5-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks5-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks5-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks5.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Friends of Nagdy comforted each other on Monday.</figcaption></figure>
<figure id="attachment_76374" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76374" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks6-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks6-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks6-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks6-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks6.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">The vigil started in the 2100 block of Crittenden Drive where Travis Nagdy was killed on Monday.</figcaption></figure>
<figure id="attachment_76375" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76375" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks7-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks7-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks7-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks7-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks7.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Flowers were placed on the ground where Travis Nagdy was shot on Monday.</figcaption></figure>
<figure id="attachment_76377" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76377" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks10-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks10-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks10-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks10-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks10.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Candles were placed in Jefferson Square Park on Monday night in honor of social justice activist Travis Nagdy.</figcaption></figure>
<figure id="attachment_76378" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76378" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks12-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks12-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks12-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks12-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks12.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Candles were lit in Jefferson Square Park to spell out &#8216;Travis&#8217; as the park filled with friends, family and fellow protesters to honor him.</figcaption></figure>
<figure id="attachment_76379" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76379" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks14-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks14-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks14-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks14-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks14.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Candles, flowers and photos of Nagdy filled Jefferson Square Park on Monday night.</figcaption></figure>
<figure id="attachment_76380" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76380" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks16-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks16-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks16-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks16-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks16.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Christina Muimneach was surrounded by friends of her son Travis Nagdy.</figcaption></figure>
<figure id="attachment_76381" style="width: 1024px" class="wp-caption alignnone"><img class="size-large wp-image-76381" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks20-1024x683.jpg" alt="" width="1024" height="683" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks20-1024x683.jpg 1024w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks20-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks20-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks20.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text">Friends, family and fellow protesters took turns telling stories about their time with Nagdy and his dedication to fighting for equality and for justice for Breonna Taylor.</figcaption></figure>
<figure id="attachment_76385" style="width: 800px" class="wp-caption alignnone"><img class="size-large wp-image-76385" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks33.jpg" alt="" width="800" height="800" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks33.jpg 800w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks33-150x150.jpg 150w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks33-300x300.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyPicks33-768x768.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /><figcaption class="wp-caption-text">Mourners raised their fists and chanted in honor of Travis Nagdy at Jefferson Square Park.</figcaption></figure>
<figure id="attachment_76397" style="width: 1200px" class="wp-caption alignnone"><img class="size-full wp-image-76397" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-5.jpg" alt="" width="1200" height="800" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-5.jpg 1200w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-5-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-5-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-5-1024x683.jpg 1024w" sizes="(max-width: 1200px) 100vw, 1200px" /><figcaption class="wp-caption-text">Travis Nagdy spoke to protesters on a megaphone in front of the Kentucky Derby Festival office during a protest.</figcaption></figure>
<figure id="attachment_76398" style="width: 1200px" class="wp-caption alignnone"><img class="size-full wp-image-76398" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-8.jpg" alt="" width="1200" height="800" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-8.jpg 1200w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-8-300x200.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-8-768x512.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/11/LEO_KH_TravisNagdyArchives-8-1024x683.jpg 1024w" sizes="(max-width: 1200px) 100vw, 1200px" /><figcaption class="wp-caption-text">Travis Nagdy spoke to police at the protest outside of Senator Mitch McConnell&#8217;s home during a protest.</figcaption></figure>
</p>                        
            
        </div>
        <footer>
            <div class="post-meta">
                Published under <a href="https://www.leoweekly.com/category/news/" rel="category tag">News</a>             </div>
            <div class="sharing">
                <div class="addthis_sharing_toolbox"></div>
            </div>

                    </footer>
        
<section id="comments" class="comments">
    <header>
        <h3>Comments</h3>
    </header>
    <div class="fb-comments" data-href="https://www.leoweekly.com/2020/11/hundreds-mourn-death-passionate-black-lives-matter-activist-travis-nagdy/" data-width="100%" data-numposts="5" data-colorscheme="light" data-order-by="social"></div>
</section>
<section id="related" class="related">
    <header>
        <h3>Recommended for you</h3>
    </header>
    <div id="related-posts" data-related-id="76369"></div>
</section>

<script type="text/template" class="related-post-template">
    <div class="row">
    <% _.each( rp, function( relatedPost, i ){ %>
        <% if( i % 3 === 0 && i > 1 ) { %>
            </div><div class="row">
        <% } %>
        <%
            var image = relatedPost.thumbnail || 'https://www.leoweekly.com/wp-content/themes/leo/assets/img/leo_placeholder.jpg';
        %>
        <div class="related-post col-sm-4">
            <a href="<%- relatedPost.url %>">
                <span class="category cat-<%- relatedPost.category.slug %>"><%- relatedPost.category.name %></span>
                <div class="image" style="background-image: url(<%- image %>)"></div>
                <h4><%- relatedPost.title %></h4>
                <time><%- relatedPost.date %></time>
            </a>
        </div>
    <% }); %>
    </div>
</script>
    </article>
        </main><!-- /.main -->
                    <aside class="sidebar" role="complementary">
                <div class="affix-helper">
                    


<section class="widget ajdg_grpwidgets-2 ajdg_grpwidgets"><div class="g g-2"><div class="g-single a-997"><a class="gofollow" data-track="OTk3LDIsMSw2MA==" href="http://poespetdepot.com/"><img src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/10/1020_Poes_leo_winner_digital_ads_300x250.jpg" /></a></div></div></section><section class="widget text-22 widget_text"><h3>Follow Us</h3>			<div class="textwidget"><div class="fb-page" data-href="https://www.facebook.com/theleoweekly" data-tabs="timeline" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/theleoweekly" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/theleoweekly">LEO Weekly</a></blockquote></div></div>
		</section><section class="widget text-14 widget_text"><h3>E-Mail Newsletter</h3>			<div class="textwidget"><div id="mc_embed_signup">
<p>Join our e-mail list to receive LEO exclusives and special offers on tickets and giveaways.</p>

                <div class='gf_browser_chrome gform_wrapper' id='gform_wrapper_3' ><div id='gf_3' class='gform_anchor' tabindex='-1'></div><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_3' id='gform_3'  action='/2020/11/hundreds-mourn-death-passionate-black-lives-matter-activist-travis-nagdy/#gf_3'>
                        <div class='gform_body'><ul id='gform_fields_3' class='gform_fields top_label form_sublabel_below description_below'><li id='field_3_1'  class='gfield field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_3_1' >Email Address</label><div class='ginput_container ginput_container_email'>
                            <input name='input_1' id='input_3_1' type='email' value='' class='large'     aria-invalid="false" />
                        </div></li>
                            </ul></div>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_3' class='gform_button button' value='Subscribe'  onclick='if(window["gf_submitting_3"]){return false;}  if( !jQuery("#gform_3")[0].checkValidity || jQuery("#gform_3")[0].checkValidity()){window["gf_submitting_3"]=true;}  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_3"]){return false;} if( !jQuery("#gform_3")[0].checkValidity || jQuery("#gform_3")[0].checkValidity()){window["gf_submitting_3"]=true;}  jQuery("#gform_3").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=3&amp;title=&amp;description=&amp;tabindex=0' />
            <input type='hidden' class='gform_hidden' name='is_submit_3' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='3' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_3' value='WyJbXSIsImUyOTk3MDQ4OGUyZWUxMzU1NmRiZmQ0ODhhMGE5MGQ0Il0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_3' id='gform_target_page_number_3' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_3' id='gform_source_page_number_3' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        </form>
                        </div>
                <iframe style='display:none;width:100%;height:0px;' src='about:blank' name='gform_ajax_frame_3' id='gform_ajax_frame_3' title='This iframe contains the logic required to handle Ajax powered Gravity Forms.'></iframe>
                <script type='text/javascript'>jQuery(document).ready(function($){gformInitSpinner( 3, 'https://www.leoweekly.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery('#gform_ajax_frame_3').on('load',function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_3');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_3').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;var mt = parseInt(jQuery('html').css('margin-top'), 10) + parseInt(jQuery('body').css('margin-top'), 10) + 100;if(is_form){jQuery('#gform_wrapper_3').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_3').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_3').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_3').offset().top - mt); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_3').val();gformInitSpinner( 3, 'https://www.leoweekly.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery(document).trigger('gform_page_loaded', [3, current_page]);window['gf_submitting_3'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('.GF_AJAX_POSTBACK').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_3').replaceWith(confirmation_content);jQuery(document).scrollTop(jQuery('#gf_3').offset().top - mt);jQuery(document).trigger('gform_confirmation_loaded', [3]);window['gf_submitting_3'] = false;}, 50);}else{jQuery('#gform_3').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [3, current_page]);} );} );</script><script type='text/javascript'> jQuery(document).bind('gform_post_render', function(event, formId, currentPage){if(formId == 3) {} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} );</script><script type='text/javascript'> jQuery(document).ready(function(){jQuery(document).trigger('gform_post_render', [3, 1]) } ); </script>
<small>* No spam, we promise. Unsubscribe any time.</small>
</div></div>
		</section><section class="widget ajdg_grpwidgets-3 ajdg_grpwidgets"><div class="g g-3"><div class="g-single a-1007"><a class="gofollow" data-track="MTAwNywzLDEsNjA=" href="https://westportwhiskeyandwine.com/wine-clubs"><img src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/10/WWW-LEO-RC-2020_300x600.jpg" /></a></div></div></section>
<script type="text/template" class="trending-post-template">
    <ul class="trending-list">
    <% _.each( tp, function( trendingPost, i ){ %>
        <li><span class="count"><%- i+1 %></span> <a href="<%- trendingPost.url %>"><%- trendingPost.title %></a></li>
    <% }); %>
    </ul>
</script>
                </div>
            </aside><!-- /.sidebar -->
            </div><!-- /.content -->
</div><!-- /.wrap -->


<section class="masthead">
    <div class="container">
        <aside class="social">
            <h4>Follow Us</h4>
            <ul>
                <li><a href="https://www.facebook.com/theleoweekly" target="_blank"><i class="fa fa-facebook"></i></a></li>                <li><a href="https://www.twitter.com/leoweekly" target="_blank"><i class="fa fa-twitter"></i></a></li>                <li><a href="https://instagram.com/leoweekly" target="_blank"><i class="fa fa-instagram"></i></a></li>            </ul>
        </aside>
        <h1>Publishing Louisville's arts and entertainment news, community-focused stories, and colorful local commentary since 1990.</h1>
        <div class="officers">
                                                <span class="officer"><strong>Founder</strong> John Yarmuth</span>                                    <span class="officer break"><strong>Executive Editor</strong> Aaron Yarmuth</span> <br>                                    <span class="officer"><strong>Publisher</strong> Laura Snyder</span>                                    </div>
    </div>
</section>
<footer class="content-info" role="contentinfo">
  <div class="container">
    <div class="row">
      <div class="copyright col-md-6">
          <p>All material &copy;2020 LEO Weekly, Louisville, KY. All rights reserved.</p>
      </div>
      <div class="footer-nav col-md-6">
        <ul id="menu-footer-navigation" class="list-inline"><li class="menu-rack-locations"><a href="https://www.leoweekly.com/distribution/">Rack Locations</a></li>
<li class="menu-about"><a href="https://www.leoweekly.com/about/">About</a></li>
<li class="menu-contact"><a href="https://www.leoweekly.com/contact/">Contact</a></li>
<li class="menu-privacy"><a href="https://www.leoweekly.com/privacy/">Privacy</a></li>
</ul>      </div>
    </div>
  </div>
<!-- Quantcast Tag -->
<script>
 var ezt = ezt ||[];
 (function(){
   var elem = document.createElement('script');
   elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://pixel") + ".quantserve.com/aquant.js?a=p-a4LDpi_DEopn-";
   elem.async = true;
   elem.type = "text/javascript";
   var scpt = document.getElementsByTagName('script')[0];
   scpt.parentNode.insertBefore(elem,scpt);
 }());
 ezt.push({qacct: 'p-a4LDpi_DEopn-', uid: '' });
</script>
<noscript><img src="//pixel.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/></noscript>
<!-- End Quantcast Tag -->
<!-- Segment Pixel - LEO Weekly-Audience Extension - DO NOT MODIFY -->
<script src="https://secure.adnxs.com/seg?add=2794617&t=1" type="text/javascript"></script>
<!-- End of Segment Pixel -->
</footer>

<link rel='stylesheet' id='gforms_reset_css-css'  href='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/gravityforms/css/formreset.min.css?ver=2.4.20' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_formsmain_css-css'  href='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/gravityforms/css/formsmain.min.css?ver=2.4.20' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_ready_class_css-css'  href='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/gravityforms/css/readyclass.min.css?ver=2.4.20' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_browsers_css-css'  href='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/gravityforms/css/browsers.min.css?ver=2.4.20' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.leoweekly.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/themes/leo/assets/js/vendor/modernizr.min.js'></script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/themes/leo/assets/js/scripts.min.js?194487edabc67037f36a72f2d36b4dfa'></script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=4.9.16'></script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/gravityforms/js/jquery.json.min.js?ver=2.4.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"https:\/\/www.leoweekly.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/www.leoweekly.com\/wp-content\/plugins\/gravityforms\/images\/spinner.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/gravityforms/js/gravityforms.min.js?ver=2.4.20'></script>
<script>
        (function(b,o,i,l,e,r){b.GoogleAnalyticsObject=l;b[l]||(b[l]=
        function(){(b[l].q=b[l].q||[]).push(arguments)});b[l].l=+new Date;
    e=o.createElement(i);r=o.getElementsByTagName(i)[0];
    e.src='//www.google-analytics.com/analytics.js';
    r.parentNode.insertBefore(e,r)}(window,document,'script','ga'));
ga('create','UA-61396929-1','auto');ga('send','pageview');
</script>


</body>
</html>
