<!doctype html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <title>Comic Book Reviews: ‘Bad Mother’ and ‘Negan Lives!&#039; - LEO Weekly</title>
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta name="google-site-verification" content="4yw5m3aUj2XVqqWaiHLKYZUdpAhZOqUkOzQcKp4xnc8" />
    <meta property="fb:app_id" content="334476176751082" />

    <link rel="shortcut icon" href="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/themes/leo/assets/img/favicon.ico">
    <link rel="alternate" type="application/rss+xml" title="LEO Weekly Feed" href="https://www.leoweekly.com/feed/">
    <script type="text/javascript">
        WebFontConfig = {
            google: { families: [ 'Open+Sans:400italic,700italic,400,700:latin' ] }
        };
        (function() {
            var wf = document.createElement('script');
            wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
            '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
            wf.type = 'text/javascript';
            wf.async = 'true';
            var s = document.getElementsByTagName('script')[0];
            s.parentNode.insertBefore(wf, s);
        })();
    </script>
    <script src="https://use.typekit.net/aex1xbf.js"></script>
    <script>try{Typekit.load({ async: true });}catch(e){}</script>

    <!-- Google Tag Manager -->
    <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-MBKVHB2');</script>
    <!-- End Google Tag Manager -->

        
<!-- This site is optimized with the Yoast SEO plugin v4.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="“Bad Mother” No. 1 with art by Mike Deodato Jr. and written by Christa Faust, so far, is about a perfectly un-superhero."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.leoweekly.com/2020/09/friendly-neighborhood-comic-book-reviews-7/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Comic Book Reviews: ‘Bad Mother’ and ‘Negan Lives!&#039; - LEO Weekly" />
<meta property="og:description" content="“Bad Mother” No. 1 with art by Mike Deodato Jr. and written by Christa Faust, so far, is about a perfectly un-superhero." />
<meta property="og:url" content="https://www.leoweekly.com/2020/09/friendly-neighborhood-comic-book-reviews-7/" />
<meta property="og:site_name" content="LEO Weekly" />
<meta property="article:section" content="Arts" />
<meta property="article:published_time" content="2020-09-02T11:38:54-04:00" />
<meta property="article:modified_time" content="2020-09-02T12:38:52-04:00" />
<meta property="og:updated_time" content="2020-09-02T12:38:52-04:00" />
<meta property="og:image" content="https://www.leoweekly.com/wp-content/uploads/2020/09/AE_Comics_KrystalMoore-copy.jpg" />
<meta property="og:image:width" content="781" />
<meta property="og:image:height" content="591" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="“Bad Mother” No. 1 with art by Mike Deodato Jr. and written by Christa Faust, so far, is about a perfectly un-superhero." />
<meta name="twitter:title" content="Comic Book Reviews: ‘Bad Mother’ and ‘Negan Lives!&#039; - LEO Weekly" />
<meta name="twitter:site" content="@leoweekly" />
<meta name="twitter:image" content="https://www.leoweekly.com/wp-content/uploads/2020/09/AE_Comics_KrystalMoore-copy.jpg" />
<meta name="twitter:creator" content="@leoweekly" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.leoweekly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.15"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='leo_css-css'  href='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/themes/leo/assets/css/main.min.css?f9d1e17ad7fc19bee30be2a26755b302' type='text/css' media='all' />
<script type='text/javascript' src='//ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js'></script>
<link rel='https://api.w.org/' href='https://www.leoweekly.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.leoweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.leoweekly.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.leoweekly.com/?p=75158' />
<link rel="alternate" type="application/json+oembed" href="https://www.leoweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.leoweekly.com%2F2020%2F09%2Ffriendly-neighborhood-comic-book-reviews-7%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.leoweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.leoweekly.com%2F2020%2F09%2Ffriendly-neighborhood-comic-book-reviews-7%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.13.2 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script>window.jQuery || document.write('<script src="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/themes/leo/assets/vendor/jquery/dist/jquery.min.js?1.11.1"><\/script>')</script>

<!-- Facebook Pixel Code -->
<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>
<!-- End Facebook Pixel Code -->
<script type='text/javascript'>
  fbq('init', '1166499293750190', {}, {
    "agent": "wordpress-4.9.15-2.0.2"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>
<!-- Facebook Pixel Code -->
<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=1166499293750190&ev=PageView&noscript=1" />
</noscript>
<!-- End Facebook Pixel Code -->
</head>
<body class="post-template-default single single-post postid-75158 single-format-standard friendly-neighborhood-comic-book-reviews-7 sidebar-primary">

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MBKVHB2"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=334476176751082&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>



<header class="banner navbar navbar-default navbar-static-top" role="banner">
    <div class="brand container">
        <div class="navbar-header">
            <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".navbar-collapse">
                <span class="sr-only">Toggle navigation</span>
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
            </button>
            <a class="navbar-brand" href="https://www.leoweekly.com/"><img src="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/themes/leo/assets/img/logo.png" alt="LEO Weekly"></a>
        </div>
    </div>
    <div class="container">
                            <div class="ad ad-banner" data-ad-group-id="1" data-ajax-url="https://www.leoweekly.com/wp-admin/admin-ajax.php"></div>
            </div>
    <nav class="collapse navbar-collapse" role="navigation">
        <div class="main-nav">
            <div class="container">
                <ul id="menu-primary-navigation" class="nav navbar-nav"><li class="current-post-ancestor active current-post-parent menu-arts"><a href="https://www.leoweekly.com/category/arts/">Arts</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="https://www.leoweekly.com/2020/09/friendly-neighborhood-comic-book-reviews-7/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/09/AE_Comics_KrystalMoore-copy.jpg"></div><header><h4>Comic Book Reviews: ‘Bad Mother’ and ‘Negan Lives!&#8217;</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/08/warhols-christianity-display-speed/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/08/AE_Art_Warhol_2-300x227.jpg"></div><header><h4>Warhol’s Christianity, on display at Speed</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/07/stageone-family-theatres-3-new-virtual-plays/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/07/AE_Theater_Play_Main-300x185.jpeg"></div><header><h4>StageOne Family Theatre’s 3 new virtual plays</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/07/comedy-club-video-store-hybrid-planet-tapes-now-open/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/07/P7023207-1-300x225.jpg"></div><header><h4>Comedy club, video store hybrid Planet of the Tapes now open</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/07/humanity-archive-breathes-life-history/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/07/Art_PodcastNEW-300x182.jpg"></div><header><h4>‘The Humanity Archive’ breathes life into history: Jermaine Fowler’s podcast is evocative and impactful</h4></header></a></div></div></div></div></div></li>
<li class="menu-music"><a href="https://www.leoweekly.com/category/music/">Music</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="https://www.leoweekly.com/2020/09/arent-seeing-outdoor-stages-louisville/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/09/Music_OutdoorConcerts-1024x686.jpeg"></div><header><h4>The rise of parking lot concerts: Will we see more outdoor shows in Louisville?</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/08/louisville-babylon-returns-misfits-covers/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/08/Music_Babylon2-300x298.jpg"></div><header><h4>Louisville Babylon returns with more Misfits covers</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/08/7-new-songs-louisville-musicians/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/08/Music_Songs-300x157.jpg"></div><header><h4>7 new songs from Louisville musicians</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/08/rb-artist-zaniah-harris-new-songs-evolution/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/08/Music_Zaniah-300x199.jpg"></div><header><h4>The journey to &#8216;Moon&#8217;: R&#038;B artist Zaniah Harris on her new song’s evolution</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/plugged-in/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2019/08/Music_PluggedIn_2_90035516-300x157.jpg"></div><header><h4>Plugged-in</h4></header></a></div></div></div></div></div></li>
<li class="menu-news"><a href="https://www.leoweekly.com/category/news/">News</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="https://www.leoweekly.com/2020/09/thorns-roses-worst-best-absurd-9-02/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2019/12/News_ThornsRoses_A-2-1024x536.jpg"></div><header><h4>Thorns and Roses: The Worst, Best and Most Absurd (9/02)</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/09/children-march-paint-highlight-protest/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/09/LEO_KH_YouthArtShowcase_-6-300x200.jpg"></div><header><h4>Photo Set: Children march and paint to highlight protest</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/09/fachin-parte-soon-hope-not-miss/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/09/DanCanonnew-300x200.jpg"></div><header><h4>‘FACHIN PARTE SOON’&#8230; Hope I did not miss it</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/09/let-eat-cake-open-letter-bill-carstanjen-ceo-churchill-downs-inc/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/06/SP_Speed_HannahDrake-1024x537-300x157.jpg"></div><header><h4>Let Them Eat Cake: An Open Letter to Bill Carstanjen, CEO of Churchill Downs Inc.</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/09/dont-cancel-derby-use/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2019/12/Views_EN_AaronYarmuth_A-1-300x157.jpg"></div><header><h4>Don’t cancel Derby — use it!</h4></header></a></div></div></div></div></div></li>
<li class="menu-food-drink"><a href="https://www.leoweekly.com/category/food-drink/">Food &#038; Drink</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="https://www.leoweekly.com/2020/09/finishing-school-whiskeys-spend-time-secondary-barrels/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/09/Bourbon-Barrel-1024x497.jpeg"></div><header><h4>Finishing school: Whiskeys that spend time in secondary barrels</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/09/lou-brew-scene-grows-despite-covid-19/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/09/FoodDrink_BM_Roundup-01-300x175.jpg"></div><header><h4>Lou brew scene grows despite COVID-19</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/09/tiny-thai-cafe-favorite/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/09/FoodDrink_R_ThaiCafe_corncakes-300x225.jpg"></div><header><h4>Tiny Thai Cafe, a favorite</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/2020/08/pandemic-el-mundo-highlands-opened/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/08/FoodDrink_R_Mundo2_carnitas_landscape-300x217.jpg"></div><header><h4>El Mundo Highlands has opened</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/2020/08/pollo-chicken-food-truck-lands-clifton-storefront/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/08/FoodDrink_R_Pollo_chixwaffle-300x225.jpg"></div><header><h4>Pollo chicken food truck lands in Clifton storefront</h4></header></a></div></div></div></div></div></li>
<li class="menu-staffpicks"><a href="https://www.leoweekly.com/category/staffpicks/">Staffpicks</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="https://www.leoweekly.com/event/wim-botha-still-life-discontent/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/09/SP_Botha.jpg"></div><header><h4>‘Wim Botha: Still Life With Discontent’</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/event/tom-pfannerstill-emily-church-ray-kleinhelter/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/09/SP_Hertz-140x300.jpg"></div><header><h4>Tom Pfannerstill, Emily Church And Ray Kleinhelter</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/event/racial-justice-series-healthy-home-healthy-work/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/09/SP_HealthAtHome-240x300.jpg"></div><header><h4>Racial Justice Series — Healthy At Home?  Healthy At Work?</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="https://www.leoweekly.com/event/100-miles-breonna-taylor-1/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/09/SP_100Miles-300x281.png"></div><header><h4>100 Miles For Breonna Taylor #1</h4></header></a></div><div class="recent-item"><a href="https://www.leoweekly.com/event/ya-ya-highlands-cleanup/"><div class="featured-image" data-featured-image="https://www.leoweekly.com/wp-content/uploads/2020/09/SP_YaYaCleanup-300x208.jpg"></div><header><h4>Ya Ya Highlands Cleanup</h4></header></a></div></div></div></div></div></li>
<li class="menu-beer"><a href="https://www.leoweekly.com/beer-guide/">Beer</a></li>
<li class="menu-promos"><a href="https://www.leoweekly.com/promos/">Promos</a></li>
<li class="mobile-only menu-plugged-in"><a href="https://www.leoweekly.com/plugged-in/">Plugged-in</a></li>
</ul>            </div>
        </div>
        <div class="secondary-nav">
            <div class="container">
                <ul id="menu-secondary-navigation" class="nav navbar-nav nav-secondary"><li class="highlight-green menu-margaritas"><a href="https://www.leoweekly.com/margaritas-in-the-ville/">Margaritas</a></li>
<li class="highlight-teal menu-readers-choice"><a href="https://www.leoweekly.com/readers-choice/">Readers&#8217; Choice</a></li>
<li class="highlight-blue menu-literary-leo"><a href="/literary-leo-2019">Literary LEO</a></li>
<li class="menu-shop"><a href="http://shop.leoweekly.com/">Shop</a></li>
<li class="highlight-red-orange menu-red-pin-tix"><a target="_blank" href="http://LouisvilleTickets.com">Red Pin Tix</a></li>
<li class="search"><a href="/search/" class="btn-search-toggle"><i class="fa fa-search"></i></a></li></ul>                <div class="searchform"><form role="search" method="get" class="search-form form-inline" action="https://www.leoweekly.com/">
  <label class="sr-only">Search for:</label>
  <div class="input-group">
    <input type="search" value="" name="s" class="search-field form-control" placeholder="Search LEO Weekly" required>
    <span class="input-group-btn">
      <button type="submit" class="search-submit btn btn-default">Search</button>
    </span>
  </div>
</form>
</div>
            </div>
        </div>
    </nav>
</header>

<div class="wrap container" role="document">
    <div class="content row">
                <main class="main" role="main">
                    <article class="post-75158 post type-post status-publish format-standard has-post-thumbnail hentry category-arts category-comics">
            <div class="featured-image clearfix">
        <a href="https://www.leoweekly.com/2020/09/friendly-neighborhood-comic-book-reviews-7/"><img width="781" height="591" src="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/09/AE_Comics_KrystalMoore-copy.jpg" class="attachment-large size-large wp-post-image" alt="Bad Mother" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/09/AE_Comics_KrystalMoore-copy.jpg 781w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/09/AE_Comics_KrystalMoore-copy-300x227.jpg 300w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/09/AE_Comics_KrystalMoore-copy-768x581.jpg 768w" sizes="(max-width: 781px) 100vw, 781px" /></a>
            </div>
        <header>
            <div class="category"><a href="https://www.leoweekly.com/category/arts/" rel="category tag">Arts</a>, <a href="https://www.leoweekly.com/category/arts/comics/" rel="category tag">Comics</a></div>
            <h1 class="entry-title">Comic Book Reviews: ‘Bad Mother’ and ‘Negan Lives!&#8217;</h1>
                        <div class="entry-meta pulled">
            <time class="updated" datetime="2020-09-02T11:38:54+00:00">
            <span class="month">Sep</span>
            <span class="day">02</span>
            <span class="year">2020</span>
        </time>
        <div class="sharing">
        <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-508fc29018b39fef" async="async"></script>
        <!-- Go to www.addthis.com/dashboard to customize your tools -->
        <div class="addthis_sharing_toolbox"></div>
    </div>
</div>
            <p class="byline author vcard">
                By                                                                                <a href="mailto:leo@leoweekly.com" rel="author" class="fn sly">Krystal Moore</a>                                                </p>
        </header>
        <div class="entry-content">

            <p class="p1"><span class="s1"><b><i>‘Bad Mother’ No. 1<br />
</i></b></span><span class="s1"><b><i>Writer Christa Faust and artist Mike Deodato Jr.<br />
</i></b></span><span class="s1"><b><i>Review by Krystal Moore, The Great Escape Louisville</i></b></span></p>
<p class="p3"><span class="s2">AWA</span> (Artists Writers &amp; Artisans) is a new comic publisher owned and operated by creators. So far, these books have offered amazing stories, perfectly drawn. It leans toward supernatural and apocalyptic stories but not always. These stories aren’t the typical superhero comic book fare. Such is the story of this “Bad Mother.”</p>
<p class="p4">“Bad Mother” No. 1 with art by Mike Deodato Jr. and written by Christa Faust, so far, is about a perfectly un-superhero. The book opens with April, an average looking, not quite middle-aged woman, trying on jeans and coming down with that all too familiar feeling of not being perfect enough. She leaves empty handed and goes to the grocery store to carry out another mundane chore. Her husband tells her by phone he’s leaving town on business, and she shouldn’t bother trying to reach him. Her son needs laundry done, and her daughter is out past curfew. It’s just another day in the life of an American Mom. Well, until there’s a robbery at the grocery store that ends badly and eventually pulls her family into danger.</p>
<p class="p4">I don’t want to spoil anything, but let’s just say I’m looking forward to issue No. 2 to see just how bad this Mom is going to have to get!</p>
<hr />
<p class="p1"><span class="s1"><b><i>‘Negan Lives!&#8217;<br />
</i></b></span><span class="s1"><b><i>Writer Robert Kirkman and artist Charlie Adlard<br />
</i></b></span><span class="s1"><b><i>Review by Krystal Moore, The Great Escape Louisville</i></b></span></p><div class="inline-ad"><h6>Advertisement</h6><div class="ad" data-ad-group-id="4" data-ajax-url="https://www.leoweekly.com/wp-admin/admin-ajax.php"></div></div>
<p><img class="wp-image-75161 size-large alignnone" src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/09/AE_Comics_KrystalMoore_2-666x1024.jpg" alt="" width="666" height="1024" srcset="https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/09/AE_Comics_KrystalMoore_2-666x1024.jpg 666w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/09/AE_Comics_KrystalMoore_2-195x300.jpg 195w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/09/AE_Comics_KrystalMoore_2-768x1180.jpg 768w, https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/09/AE_Comics_KrystalMoore_2.jpg 781w" sizes="(max-width: 666px) 100vw, 666px" /></p>
<p class="p3"><span class="s2">Robert Kirkman</span> and Charlie Adlard decided to do something nice for comic shops hit hard by the pandemic by putting out a story that would get customers in the door for something they couldn’t resist. Thus, even though “Walking Dead’s” final issue No. 193 came out in July of 2019, we’ve been given another glimpse into that world. Since it’s Negan, expect some adult situations and language!</p>
<p class="p4">It’s hard to say where in the timeline of “Walking Dead” that this story occurs, but I had the feeling it was later in the story with fewer of the literal walking dead. Negan is at the grave of Lucille. Is it his wife or his beloved baseball bat? I won’t give away the answer, but when a girl shows up named Lucy, we begin to question if perhaps he’s dreaming? What follows is classic Negan shenanigans.</p>
<p class="p4">The book, nor its writer give any indication that this is an ongoing story, but it’s definitely left in a place with the possibility of more fun adventures with this character we all love to hate!</p>
                        
            
        </div>
        <footer>
            <div class="post-meta">
                Published under <a href="https://www.leoweekly.com/category/arts/" rel="category tag">Arts</a>, <a href="https://www.leoweekly.com/category/arts/">Arts</a>, <a href="https://www.leoweekly.com/category/arts/comics/" rel="category tag">Comics</a>             </div>
            <div class="sharing">
                <div class="addthis_sharing_toolbox"></div>
            </div>

                    </footer>
        
<section id="comments" class="comments">
    <header>
        <h3>Comments</h3>
    </header>
    <div class="fb-comments" data-href="https://www.leoweekly.com/2020/09/friendly-neighborhood-comic-book-reviews-7/" data-width="100%" data-numposts="5" data-colorscheme="light" data-order-by="social"></div>
</section>
<section id="related" class="related">
    <header>
        <h3>Recommended for you</h3>
    </header>
    <div id="related-posts" data-related-id="75158"></div>
</section>

<script type="text/template" class="related-post-template">
    <div class="row">
    <% _.each( rp, function( relatedPost, i ){ %>
        <% if( i % 3 === 0 && i > 1 ) { %>
            </div><div class="row">
        <% } %>
        <%
            var image = relatedPost.thumbnail || 'https://www.leoweekly.com/wp-content/themes/leo/assets/img/leo_placeholder.jpg';
        %>
        <div class="related-post col-sm-4">
            <a href="<%- relatedPost.url %>">
                <span class="category cat-<%- relatedPost.category.slug %>"><%- relatedPost.category.name %></span>
                <div class="image" style="background-image: url(<%- image %>)"></div>
                <h4><%- relatedPost.title %></h4>
                <time><%- relatedPost.date %></time>
            </a>
        </div>
    <% }); %>
    </div>
</script>
    </article>
        </main><!-- /.main -->
                    <aside class="sidebar" role="complementary">
                <div class="affix-helper">
                    


<section class="widget ajdg_grpwidgets-2 ajdg_grpwidgets"><div class="g g-2"><div class="g-single a-907"><a class="gofollow" data-track="OTA3LDIsMSw2MA==" href="https://www.leoweekly.com/readers-choice/"><img src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/08/RCleowebAd_ROS_300x250.jpg" /></a></div></div></section><section class="widget text-22 widget_text"><h3>Follow Us</h3>			<div class="textwidget"><div class="fb-page" data-href="https://www.facebook.com/theleoweekly" data-tabs="timeline" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/theleoweekly" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/theleoweekly">LEO Weekly</a></blockquote></div></div>
		</section><section class="widget text-14 widget_text"><h3>E-Mail Newsletter</h3>			<div class="textwidget"><div id="mc_embed_signup">
<p>Join our e-mail list to receive LEO exclusives and special offers on tickets and giveaways.</p>

                <div class='gf_browser_unknown gform_wrapper' id='gform_wrapper_3' ><div id='gf_3' class='gform_anchor' tabindex='-1'></div><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_3' id='gform_3'  action='/2020/09/friendly-neighborhood-comic-book-reviews-7/#gf_3'>
                        <div class='gform_body'><ul id='gform_fields_3' class='gform_fields top_label form_sublabel_below description_below'><li id='field_3_1'  class='gfield field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_3_1' >Email Address</label><div class='ginput_container ginput_container_email'>
                            <input name='input_1' id='input_3_1' type='email' value='' class='large'     aria-invalid="false" />
                        </div></li>
                            </ul></div>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_3' class='gform_button button' value='Subscribe'  onclick='if(window["gf_submitting_3"]){return false;}  if( !jQuery("#gform_3")[0].checkValidity || jQuery("#gform_3")[0].checkValidity()){window["gf_submitting_3"]=true;}  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_3"]){return false;} if( !jQuery("#gform_3")[0].checkValidity || jQuery("#gform_3")[0].checkValidity()){window["gf_submitting_3"]=true;}  jQuery("#gform_3").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=3&amp;title=&amp;description=&amp;tabindex=0' />
            <input type='hidden' class='gform_hidden' name='is_submit_3' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='3' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_3' value='WyJbXSIsImUyOTk3MDQ4OGUyZWUxMzU1NmRiZmQ0ODhhMGE5MGQ0Il0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_3' id='gform_target_page_number_3' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_3' id='gform_source_page_number_3' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        </form>
                        </div>
                <iframe style='display:none;width:100%;height:0px;' src='about:blank' name='gform_ajax_frame_3' id='gform_ajax_frame_3' title='This iframe contains the logic required to handle Ajax powered Gravity Forms.'></iframe>
                <script type='text/javascript'>jQuery(document).ready(function($){gformInitSpinner( 3, 'https://www.leoweekly.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery('#gform_ajax_frame_3').on('load',function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_3');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_3').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;var mt = parseInt(jQuery('html').css('margin-top'), 10) + parseInt(jQuery('body').css('margin-top'), 10) + 100;if(is_form){jQuery('#gform_wrapper_3').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_3').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_3').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_3').offset().top - mt); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_3').val();gformInitSpinner( 3, 'https://www.leoweekly.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery(document).trigger('gform_page_loaded', [3, current_page]);window['gf_submitting_3'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('.GF_AJAX_POSTBACK').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_3').replaceWith(confirmation_content);jQuery(document).scrollTop(jQuery('#gf_3').offset().top - mt);jQuery(document).trigger('gform_confirmation_loaded', [3]);window['gf_submitting_3'] = false;}, 50);}else{jQuery('#gform_3').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [3, current_page]);} );} );</script><script type='text/javascript'> jQuery(document).bind('gform_post_render', function(event, formId, currentPage){if(formId == 3) {} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} );</script><script type='text/javascript'> jQuery(document).ready(function(){jQuery(document).trigger('gform_post_render', [3, 1]) } ); </script>
<small>* No spam, we promise. Unsubscribe any time.</small>
</div></div>
		</section><section class="widget ajdg_grpwidgets-3 ajdg_grpwidgets"><div class="g g-3"><div class="g-single a-888"><a class="gofollow" data-track="ODg4LDMsMSw2MA==" href="https://502hemp.com/"><img src="http://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/uploads/2020/08/502-Hemp-newflavors-300x600.gif" /></a></div></div></section>
<script type="text/template" class="trending-post-template">
    <ul class="trending-list">
    <% _.each( tp, function( trendingPost, i ){ %>
        <li><span class="count"><%- i+1 %></span> <a href="<%- trendingPost.url %>"><%- trendingPost.title %></a></li>
    <% }); %>
    </ul>
</script>
                </div>
            </aside><!-- /.sidebar -->
            </div><!-- /.content -->
</div><!-- /.wrap -->


<section class="masthead">
    <div class="container">
        <aside class="social">
            <h4>Follow Us</h4>
            <ul>
                <li><a href="https://www.facebook.com/theleoweekly" target="_blank"><i class="fa fa-facebook"></i></a></li>                <li><a href="https://www.twitter.com/leoweekly" target="_blank"><i class="fa fa-twitter"></i></a></li>                <li><a href="https://instagram.com/leoweekly" target="_blank"><i class="fa fa-instagram"></i></a></li>            </ul>
        </aside>
        <h1>Publishing Louisville's arts and entertainment news, community-focused stories, and colorful local commentary since 1990.</h1>
        <div class="officers">
                                                <span class="officer"><strong>Founder</strong> John Yarmuth</span>                                    <span class="officer break"><strong>Executive Editor</strong> Aaron Yarmuth</span> <br>                                    <span class="officer"><strong>Publisher</strong> Laura Snyder</span>                                    </div>
    </div>
</section>
<footer class="content-info" role="contentinfo">
  <div class="container">
    <div class="row">
      <div class="copyright col-md-6">
          <p>All material &copy;2020 LEO Weekly, Louisville, KY. All rights reserved.</p>
      </div>
      <div class="footer-nav col-md-6">
        <ul id="menu-footer-navigation" class="list-inline"><li class="menu-rack-locations"><a href="https://www.leoweekly.com/distribution/">Rack Locations</a></li>
<li class="menu-about"><a href="https://www.leoweekly.com/about/">About</a></li>
<li class="menu-contact"><a href="https://www.leoweekly.com/contact/">Contact</a></li>
<li class="menu-privacy"><a href="https://www.leoweekly.com/privacy/">Privacy</a></li>
</ul>      </div>
    </div>
  </div>
<!-- Quantcast Tag -->
<script>
 var ezt = ezt ||[];
 (function(){
   var elem = document.createElement('script');
   elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://pixel") + ".quantserve.com/aquant.js?a=p-a4LDpi_DEopn-";
   elem.async = true;
   elem.type = "text/javascript";
   var scpt = document.getElementsByTagName('script')[0];
   scpt.parentNode.insertBefore(elem,scpt);
 }());
 ezt.push({qacct: 'p-a4LDpi_DEopn-', uid: '' });
</script>
<noscript><img src="//pixel.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/></noscript>
<!-- End Quantcast Tag -->
<!-- Segment Pixel - LEO Weekly-Audience Extension - DO NOT MODIFY -->
<script src="https://secure.adnxs.com/seg?add=2794617&t=1" type="text/javascript"></script>
<!-- End of Segment Pixel -->
</footer>

<link rel='stylesheet' id='gforms_reset_css-css'  href='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/gravityforms/css/formreset.min.css?ver=2.4.20' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_formsmain_css-css'  href='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/gravityforms/css/formsmain.min.css?ver=2.4.20' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_ready_class_css-css'  href='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/gravityforms/css/readyclass.min.css?ver=2.4.20' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_browsers_css-css'  href='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/gravityforms/css/browsers.min.css?ver=2.4.20' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.leoweekly.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/themes/leo/assets/js/vendor/modernizr.min.js'></script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/themes/leo/assets/js/scripts.min.js?194487edabc67037f36a72f2d36b4dfa'></script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=4.9.15'></script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/gravityforms/js/jquery.json.min.js?ver=2.4.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"https:\/\/www.leoweekly.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/www.leoweekly.com\/wp-content\/plugins\/gravityforms\/images\/spinner.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://2jnjpz34p77w1q3shs2fsoem-wpengine.netdna-ssl.com/wp-content/plugins/gravityforms/js/gravityforms.min.js?ver=2.4.20'></script>
<script>
        (function(b,o,i,l,e,r){b.GoogleAnalyticsObject=l;b[l]||(b[l]=
        function(){(b[l].q=b[l].q||[]).push(arguments)});b[l].l=+new Date;
    e=o.createElement(i);r=o.getElementsByTagName(i)[0];
    e.src='//www.google-analytics.com/analytics.js';
    r.parentNode.insertBefore(e,r)}(window,document,'script','ga'));
ga('create','UA-61396929-1','auto');ga('send','pageview');
</script>


</body>
</html>
