<!doctype html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <title>5 Things To Do This Weekend in Louisville (1/27) - LEO Weekly</title>
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta name="google-site-verification" content="4yw5m3aUj2XVqqWaiHLKYZUdpAhZOqUkOzQcKp4xnc8" />
    <meta property="fb:app_id" content="334476176751082" />

    <link rel="shortcut icon" href="http://www.leoweekly.com/wp-content/themes/leo/assets/img/favicon.ico">
    <link rel="alternate" type="application/rss+xml" title="LEO Weekly Feed" href="http://www.leoweekly.com/feed/">
    <script type="text/javascript">
        WebFontConfig = {
            google: { families: [ 'Open+Sans:400italic,700italic,400,700:latin' ] }
        };
        (function() {
            var wf = document.createElement('script');
            wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
            '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
            wf.type = 'text/javascript';
            wf.async = 'true';
            var s = document.getElementsByTagName('script')[0];
            s.parentNode.insertBefore(wf, s);
        })();
    </script>
    <script src="https://use.typekit.net/aex1xbf.js"></script>
    <script>try{Typekit.load({ async: true });}catch(e){}</script>
        
<!-- This site is optimized with the Yoast SEO plugin v4.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Louisville Championship Arm Wrestling, We Are the Weirdos, Mister! and more events that are happening in Louisville this weekend..."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://www.leoweekly.com/2017/01/5-things-to-do-this-weekend-in-louisville-120/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="5 Things To Do This Weekend in Louisville (1/27) - LEO Weekly" />
<meta property="og:description" content="Louisville Championship Arm Wrestling, We Are the Weirdos, Mister! and more events that are happening in Louisville this weekend..." />
<meta property="og:url" content="http://www.leoweekly.com/2017/01/5-things-to-do-this-weekend-in-louisville-120/" />
<meta property="og:site_name" content="LEO Weekly" />
<meta property="article:section" content="Get out!" />
<meta property="article:published_time" content="2017-01-27T12:47:59-05:00" />
<meta property="article:modified_time" content="2017-01-27T14:58:52-05:00" />
<meta property="og:updated_time" content="2017-01-27T14:58:52-05:00" />
<meta property="og:image" content="http://www.leoweekly.com/wp-content/uploads/2017/01/LCAW2345.jpg" />
<meta property="og:image:width" content="5472" />
<meta property="og:image:height" content="3286" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Louisville Championship Arm Wrestling, We Are the Weirdos, Mister! and more events that are happening in Louisville this weekend..." />
<meta name="twitter:title" content="5 Things To Do This Weekend in Louisville (1/27) - LEO Weekly" />
<meta name="twitter:site" content="@leoweekly" />
<meta name="twitter:image" content="http://www.leoweekly.com/wp-content/uploads/2017/01/LCAW2345.jpg" />
<meta name="twitter:creator" content="@leoweekly" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.leoweekly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.3"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='HZ-FRCW-STYLE-css'  href='http://www.leoweekly.com/wp-content/plugins/fb-recent-comments-widget/css/style.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='leo_css-css'  href='http://www.leoweekly.com/wp-content/themes/leo/assets/css/main.min.css?46bfbcfd618aed16b9dbd4a5a5d3913d' type='text/css' media='all' />
<script type='text/javascript' src='//ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js'></script>
<script>window.jQuery || document.write('<script src="http://www.leoweekly.com/wp-content/themes/leo/assets/vendor/jquery/dist/jquery.min.js?1.11.1"><\/script>')</script>
<script type='text/javascript' src='http://www.leoweekly.com/wp-content/plugins/fb-recent-comments-widget/js/jquery.timeago.js?ver=4.6.3'></script>
<script type='text/javascript' src='http://www.leoweekly.com/wp-content/plugins/fb-recent-comments-widget/js/js.js?ver=4.6.3'></script>
<link rel='https://api.w.org/' href='http://www.leoweekly.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.leoweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.leoweekly.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='http://www.leoweekly.com/?p=37506' />
<link rel="alternate" type="application/json+oembed" href="http://www.leoweekly.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.leoweekly.com%2F2017%2F01%2F5-things-to-do-this-weekend-in-louisville-120%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.leoweekly.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.leoweekly.com%2F2017%2F01%2F5-things-to-do-this-weekend-in-louisville-120%2F&#038;format=xml" />

<!-- This site is using AdRotate v3.18.1 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

</head>
<body class="single single-post postid-37506 single-format-standard 5-things-to-do-this-weekend-in-louisville-120 sidebar-primary">

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=334476176751082&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>



<header class="banner navbar navbar-default navbar-static-top" role="banner">
    <div class="brand container">
        <div class="navbar-header">
            <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".navbar-collapse">
                <span class="sr-only">Toggle navigation</span>
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
            </button>
            <a class="navbar-brand" href="http://www.leoweekly.com/"><img src="http://www.leoweekly.com/wp-content/themes/leo/assets/img/logo.png" alt="LEO Weekly"></a>
        </div>
    </div>
    <div class="container">
                            <div class="ad ad-banner" data-ad-group-id="1" data-ajax-url="http://www.leoweekly.com/wp-admin/admin-ajax.php"></div>
            </div>
    <nav class="collapse navbar-collapse" role="navigation">
        <div class="main-nav">
            <div class="container">
                <ul id="menu-primary-navigation" class="nav navbar-nav"><li class="menu-arts"><a href="http://www.leoweekly.com/category/arts/">Arts</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="http://www.leoweekly.com/2017/01/circle-mirror-transformation-%e2%80%a8whats-happening-us-right-now/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/AE_Theater_CircleMirror_byBillBrymer-1024x536.jpg"></div><header><h4>‘Circle Mirror Transformation,&#8217; &#8216;what’s happening to us right now’</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/tim-northern-comedy-funny-not-agenda/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/AE_Comedy_TimNorthern-300x157.jpg"></div><header><h4>Tim Northern, comedy is being funny, not about an agenda</h4></header></a></div><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/midnight-cool-story-charming-horse-traders/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/AE_Books_MidnightCool_LydiaPeelle_byAndreaBehrends-300x157.jpg"></div><header><h4>‘The Midnight Cool,’ a story of charming WWI horse traders</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/big-gay-italian-mid-life-crisis-fun-fast-paced/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/AE_Theater_MyGayItalian_CourtesyPandoraProductions-300x157.jpg"></div><header><h4>‘My Big Gay Italian Mid-Life Crisis,’ fun, fast-paced</h4></header></a></div><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/patrick-spring-ill-give-reason-run-town/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/AE_Comedy_PatrickSpring_2-300x157.jpg"></div><header><h4>Patrick Spring, ‘I’ll give you a reason to run me out of your town’</h4></header></a></div></div></div></div></div></li>
<li class="menu-music"><a href="http://www.leoweekly.com/category/music/">Music</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="http://www.leoweekly.com/2017/01/new-music-roundup-white-reaper-heidi-howe-frederick-younger-james-lindsey-kaleidico/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/HeidiHowe12.jpg"></div><header><h4>New music roundup: White Reaper, Heidi Howe, Frederick The Younger, James Lindsey, Kaleidico</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/leo-presents-tender-mercy-live-studio/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/Screen-Shot-2017-01-27-at-2.26.14-PM-300x160.png"></div><header><h4>LEO Presents: Tender Mercy live in studio</h4></header></a></div><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/kaleidicos-new-record-dives-isolation-uncertainty/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/Music_Feature_Kaleidico_byNikVechery-300x157.jpg"></div><header><h4>Kaleidico’s new record dives into isolation and uncertainty</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/a-lion-named-roar/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/Music_bsides_ALionNamedRoar-300x157.jpg"></div><header><h4>A Lion Named Roar talks about new music</h4></header></a></div><div class="recent-item"><a href="http://www.leoweekly.com/plugged-in/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2015/11/Music_PluggedIn_2_90035516-13-300x157.jpg"></div><header><h4>Plugged-in</h4></header></a></div></div></div></div></div></li>
<li class="menu-news"><a href="http://www.leoweekly.com/category/news/">News</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="http://www.leoweekly.com/2017/01/ode-phoenix-hill-tavern/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/News_Phoenix_1_ByWillRussell-1024x536.jpg"></div><header><h4>An ode to Phoenix Hill Tavern</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/we-have-a-mitch-problem/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/News_Mitch_byCarrieNeumayer-1-300x157.jpg"></div><header><h4>We have a Mitch problem&#8230;</h4></header></a></div><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/leo-verse/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2016/12/feature_TrumpRallyFace-300x124.jpg"></div><header><h4>LEO-verse: A Poem for Trump&#8217;s Inauguration</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/thorns-roses-worst-best-26/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/News_ThornsRoses-3-300x157.jpg"></div><header><h4>Thorns &#038; Roses: The Worst &#038; Best</h4></header></a></div><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/offensive-tweets-expectbetterfromuofl/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2016/11/GuestCommentary_Lion-copy-2-300x252.jpg"></div><header><h4>Offensive tweets: #ExpectBetterFromUofL</h4></header></a></div></div></div></div></div></li>
<li class="menu-food-drink"><a href="http://www.leoweekly.com/category/food-drink/">Food &#038; Drink</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="http://www.leoweekly.com/2017/01/cans-aplenty-way-tailspin-ale-fest-cometh/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/FoodDrink_IdTapThat_FourPegs.jpg"></div><header><h4>Cans aplenty on the way, Tailspin Ale Fest cometh</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/consistency-is-key/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/FoodDrink_IndustryStandard_MarshaLynch-1-300x173.jpg"></div><header><h4>Consistency is Key</h4></header></a></div><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/barkeep-d-c/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/FoodDrink_BarkeepConfessions_2_KelseyWestbrook-1-300x157.jpg"></div><header><h4>The Barkeep Does D.C.</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/mashed-potato-pizza-try-charlestown-pizza-co/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/FoodDrink_Recommended__CharlestownPizza_Pizza-300x157.jpg"></div><header><h4>Mashed potato pizza? Try it at Charlestown Pizza Co.</h4></header></a></div><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/tater-tots-grown-ups/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/FoodDrink_TheTasteBud_Gibson-1-300x173.jpg"></div><header><h4>Tater tots for grown-ups</h4></header></a></div></div></div></div></div></li>
<li class="menu-staffpicks"><a href="http://www.leoweekly.com/category/staffpicks/">Staffpicks</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="http://www.leoweekly.com/event/we-are-the-weirdos-mister/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/SP_WeAreTheWeirdosMister_130745025-1024x536.jpg"></div><header><h4>STAFF PICK: We Are the Weirdos, Mister!</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="http://www.leoweekly.com/event/louisville-voices-unity-peace-songs-social-justice/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/SP_VoicesOfUnityAndPeace-300x157.jpg"></div><header><h4>STAFF PICK: Louisville Voices of Unity and Peace: Songs of Social Justice</h4></header></a></div><div class="recent-item"><a href="http://www.leoweekly.com/event/4th-annual-community-seed-swap/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/SP_SeedSwap_96627397-300x157.jpg"></div><header><h4>4th Annual Community Seed Swap</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="http://www.leoweekly.com/event/prohibition-parlour-love-lace/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/SP_ProhibitionParlour_byOliviaRoseGriffin-300x157.jpg"></div><header><h4>Prohibition Parlour: Love &#038; Lace</h4></header></a></div><div class="recent-item"><a href="http://www.leoweekly.com/event/moth-storyslam-voyage/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/SP_MothStorySlam_119945861-300x157.jpg"></div><header><h4>The Moth StorySLAM: Voyage</h4></header></a></div></div></div></div></div></li>
<li class="menu-modern"><a href="http://www.leoweekly.com/category/modern-louisville/">Modern</a><div class="mega-menu container"><div class="row"><div class="top-story"><h3>Top Story</h3><a href="http://www.leoweekly.com/2017/01/louisville-video-game-artist-brings-lgbtq-characters-mainstream/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/Modern_Videogame_DeadCentury_5-1024x536.jpg"></div><header><h4>Louisville Video-Game Artist Brings LGBTQ Characters to Mainstream</h4></header></a></div><div class="recent-stories"><h3>Recent</h3><div class="row"><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/a-double-dose/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/KulbakoHR_7146-300x199.jpg"></div><header><h4>A Double Dose of AC</h4></header></a></div><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/standing-tall/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/Suicide-300x157.jpg"></div><header><h4>Standing Tall</h4></header></a></div></div><div class="row"><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/the-fluidity-of-definition/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/Queer-300x157.jpg"></div><header><h4>The Fluidity of Definition</h4></header></a></div><div class="recent-item"><a href="http://www.leoweekly.com/2017/01/wellness-well-being/"><div class="featured-image" data-featured-image="http://www.leoweekly.com/wp-content/uploads/2017/01/HealthDSC_5891-300x214.jpg"></div><header><h4>Wellness &#038; Well-Being</h4></header></a></div></div></div></div></div></li>
<li class="menu-promos"><a href="http://www.leoweekly.com/promos/">Promos</a></li>
<li class="mobile-only menu-plugged-in"><a href="http://www.leoweekly.com/plugged-in/">Plugged-in</a></li>
</ul>            </div>
        </div>
        <div class="secondary-nav">
            <div class="container">
                <ul id="menu-secondary-navigation" class="nav navbar-nav nav-secondary"><li class="menu-issues"><a href="http://www.leoweekly.com/issues/">Issues</a></li>
<li class="menu-web-exclusive"><a href="http://www.leoweekly.com/category/web-only/">Web Exclusive</a></li>
<li class="highlight menu-literary-leo-info-for-the-2017-party"><a href="http://www.leoweekly.com/literary-leo-0/">Literary LEO: Info for the 2017 party</a></li>
<li class="search"><a href="/search/" class="btn-search-toggle"><i class="fa fa-search"></i></a></li></ul>                <div class="searchform"><form role="search" method="get" class="search-form form-inline" action="http://www.leoweekly.com/">
  <label class="sr-only">Search for:</label>
  <div class="input-group">
    <input type="search" value="" name="s" class="search-field form-control" placeholder="Search LEO Weekly" required>
    <span class="input-group-btn">
      <button type="submit" class="search-submit btn btn-default">Search</button>
    </span>
  </div>
</form>
</div>
            </div>
        </div>
    </nav>
</header>

<div class="wrap container" role="document">
    <div class="content row">
                <main class="main" role="main">
                    <article class="post-37506 post type-post status-publish format-standard has-post-thumbnail hentry category-get-out">
            <div class="featured-image clearfix">
        <a href="http://www.leoweekly.com/2017/01/5-things-to-do-this-weekend-in-louisville-120/"><img width="1024" height="615" src="http://www.leoweekly.com/wp-content/uploads/2017/01/LCAW2345-1024x615.jpg" class="attachment-large size-large wp-post-image" alt="LCAW2345" srcset="http://www.leoweekly.com/wp-content/uploads/2017/01/LCAW2345-1024x615.jpg 1024w, http://www.leoweekly.com/wp-content/uploads/2017/01/LCAW2345-300x180.jpg 300w, http://www.leoweekly.com/wp-content/uploads/2017/01/LCAW2345-768x461.jpg 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></a>
            </div>
        <header>
            <div class="category"><a href="http://www.leoweekly.com/category/get-out/" rel="category tag">Get out!</a></div>
            <h1 class="entry-title">5 Things To Do This Weekend in Louisville (1/27)</h1>
                        <div class="entry-meta pulled">
    <time class="updated" datetime="2017-01-27T12:47:59+00:00">
        <span class="month">Jan</span>
        <span class="day">27</span>
        <span class="year">2017</span>
    </time>
    <div class="sharing">
        <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-508fc29018b39fef" async="async"></script>
        <!-- Go to www.addthis.com/dashboard to customize your tools -->
        <div class="addthis_sharing_toolbox"></div>
    </div>
</div>
            <p class="byline author vcard">
                By                                                                                <a href="mailto:esmith@leoweekly.com" rel="author" class="fn sly">Ethan Smith</a>                                                </p>
        </header>
        <div class="entry-content">

            <h1><b>FRIDAY</b></h1>
<p><a href="https://www.facebook.com/events/177077266091000/" target="_blank"><b>We Are the Weirdos, Mister!<br />
</b></a><b>Cure Lounge<br />
</b><b>$10-$17  |  9 p.m.<br />
</b><span style="font-weight: 400;">“We Are the Weirdos, Mister!” is a macabre night of entertainment with members of Louisville’s strangest groups: Octo Claw&#8217;s Bizarre Bizaar, Vaudeville Louisville, Suspend Performing Arts, Suicide Squad and Va Va Vixens. It’s a chance to let your freak flag fly, and enjoy acts of burlesque, aerials, drag and sideshow!</span></p>
<p><a href="https://www.facebook.com/events/1790004137990853/" target="_blank"><b>Alone &amp; Together: Evan Patterson, Aaron West and Charles Rivera<br />
</b></a><b>Kaiju<br />
</b><b>$5  |  9 p.m.-1 a.m.<br />
</b><span style="font-weight: 400;">Alone &amp; Together is a new concert series featuring prominent Louisville musicians performing solo sets, followed by a collaborative, improvised performance at the end of the night. This inaugural edition of Alone &amp; Together will feature Evan Patterson of Jaye Jayle and Young Widows, Aaron West of Quiet Hollers and Charles Rivera of Stook and Pleasure Boys.</span></p>
<h1><b></b><b>SATURDAY</b></h1>
<p><strong><a href="https://www.facebook.com/events/164132037409662/" target="_blank">We Welcome Refugees<br />
</a>Church of the Advent (901 Baxter Ave.)</strong><br />
<strong>Free  |  1 p.m.</strong><br />
Join the Episcopal Diocese of Kentucky for prayers and statements of support for our refugee neighbors in Louisville. At this gathering, the diocese (in the words of the presiding bishop) will “ask President Trump to continue the powerful work of our refugee resettlement program without interruption.&#8221; Because everyone deserves a chance at a better life, no matter what scared little men with small hands say.</p><div class="inline-ad"><h6>Advertisement</h6><div class="ad" data-ad-group-id="4" data-ajax-url="http://www.leoweekly.com/wp-admin/admin-ajax.php"></div></div>
<p><a href="http://do502.com/events/2017/1/28/bryan-bandit-lougz-gee-david-haze-mb-cobi-rosario-brxtn-dj-mase-gawd" target="_blank"><b>Louisville Independent Talent presents Bryan Bandit, BRXTN and more!<br />
</b></a><b>The Green Building (732 E. Market St.)<br />
</b><b>$5  |  8 p.m.<br />
</b><span style="font-weight: 400;">This Saturday, Louisville Independent Talent presents a night packed with the best in local hip-hop. Curated by local hip-hop supporter Marissa Mitchell, this show features acts by BRXTN, Rosario and Lougz Gee, David Haze, MB Cobi and Bryan Bandit of The Choom$, followed by a special set by DJ Mase Gawd.</span></p>
<p><a href="https://www.facebook.com/events/209438519454532/" target="_blank"><b>LCAW: Darkness On The Edge of Town<br />
</b></a><b>Kaiju<br />
</b><b>Free  |  10 p.m.<br />
</b><span style="font-weight: 400;">This event is best described by Louisville Championship Arm Wrestling’s own Jon Becraft, aka Buck Dungle: “We wanted to present all the tropes of wrestling to a theater crowd … since none of us had any experience in wrestling, we went with arm wrestling.” It’s all the fun of going to a campy wrestling match, except instead of being surrounded by juggalos, you’re surrounded by drunken theater geeks.</span></p>
                        
            
        </div>
        <footer>
            <div class="post-meta">
                Published under <a href="http://www.leoweekly.com/category/get-out/" rel="category tag">Get out!</a>             </div>
            <div class="sharing">
                <div class="addthis_sharing_toolbox"></div>
            </div>

                    </footer>
        
<section id="comments" class="comments">
    <header>
        <h3>Comments</h3>
    </header>
    <div class="fb-comments" data-href="http://www.leoweekly.com/2017/01/5-things-to-do-this-weekend-in-louisville-120/" data-width="100%" data-numposts="5" data-colorscheme="light" data-order-by="social"></div>
</section>
<section id="related" class="related">
    <header>
        <h3>Recommended for you</h3>
    </header>
    <div id="related-posts" data-related-id="37506"></div>
</section>

<script type="text/template" class="related-post-template">
    <div class="row">
    <% _.each( rp, function( relatedPost, i ){ %>
        <% if( i % 3 === 0 && i > 1 ) { %>
            </div><div class="row">
        <% } %>
        <%
            var image = relatedPost.thumbnail || 'http://www.leoweekly.com/wp-content/themes/leo/assets/img/leo_placeholder.jpg';
        %>
        <div class="related-post col-sm-4">
            <a href="<%- relatedPost.url %>">
                <span class="category cat-<%- relatedPost.category.slug %>"><%- relatedPost.category.name %></span>
                <div class="image" style="background-image: url(<%- image %>)"></div>
                <h4><%- relatedPost.title %></h4>
                <time><%- relatedPost.date %></time>
            </a>
        </div>
    <% }); %>
    </div>
</script>
    </article>
        </main><!-- /.main -->
                    <aside class="sidebar" role="complementary">
                <div class="affix-helper">
                    


<section class="widget adrotate_widgets-2 widget_adrotate_widgets"><!-- Error, Ad is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></section><section class="widget trending-2 widget_trending"><h3>Trending</h3><div id="trending-posts"></div></section><section class="widget adrotate_widgets-3 widget_adrotate_widgets"><!-- Error, Ad is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></section><section class="widget text-22 widget_text"><h3>Follow Us</h3>			<div class="textwidget"><div class="fb-page" data-href="https://www.facebook.com/theleoweekly" data-tabs="timeline" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/theleoweekly" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/theleoweekly">LEO Weekly</a></blockquote></div></div>
		</section><section class="widget text-14 widget_text"><h3>E-Mail Newsletter</h3>			<div class="textwidget"><div id="mc_embed_signup">
<p>Join our e-mail list to receive LEO exclusives and special offers on tickets and giveaways.</p>

                <div class='gf_browser_unknown gform_wrapper' id='gform_wrapper_3' ><a id='gf_3' class='gform_anchor' ></a><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_3' id='gform_3'  action='/2017/01/5-things-to-do-this-weekend-in-louisville-120/#gf_3'>
                        <div class='gform_body'><ul id='gform_fields_3' class='gform_fields top_label form_sublabel_below description_below'><li id='field_3_1' class='gfield field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_3_1' >Email Address</label><div class='ginput_container ginput_container_email'>
                            <input name='input_1' id='input_3_1' type='email' value='' class='large' tabindex='1'   />
                        </div></li>
                            </ul></div>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_3' class='gform_button button' value='Subscribe' tabindex='2' onclick='if(window["gf_submitting_3"]){return false;}  if( !jQuery("#gform_3")[0].checkValidity || jQuery("#gform_3")[0].checkValidity()){window["gf_submitting_3"]=true;}  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_3"]){return false;} if( !jQuery("#gform_3")[0].checkValidity || jQuery("#gform_3")[0].checkValidity()){window["gf_submitting_3"]=true;}  jQuery("#gform_3").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=3&amp;title=&amp;description=&amp;tabindex=1' />
            <input type='hidden' class='gform_hidden' name='is_submit_3' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='3' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_3' value='WyJbXSIsImUyOTk3MDQ4OGUyZWUxMzU1NmRiZmQ0ODhhMGE5MGQ0Il0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_3' id='gform_target_page_number_3' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_3' id='gform_source_page_number_3' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        </form>
                        </div>
                <iframe style='display:none;width:0px;height:0px;' src='about:blank' name='gform_ajax_frame_3' id='gform_ajax_frame_3' title='Ajax Frame'>This iframe contains the logic required to handle AJAX powered Gravity Forms.</iframe>
                <script type='text/javascript'>jQuery(document).ready(function($){gformInitSpinner( 3, 'http://www.leoweekly.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery('#gform_ajax_frame_3').load( function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_3');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_3').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;if(is_form){jQuery('#gform_wrapper_3').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_3').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_3').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_3').offset().top); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_3').val();gformInitSpinner( 3, 'http://www.leoweekly.com/wp-content/plugins/gravityforms/images/spinner.gif' );jQuery(document).trigger('gform_page_loaded', [3, current_page]);window['gf_submitting_3'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('#gforms_confirmation_message_3').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_3').replaceWith('<' + 'div id=\'gforms_confirmation_message_3\' class=\'gform_confirmation_message_3 gforms_confirmation_message\'' + '>' + confirmation_content + '<' + '/div' + '>');jQuery(document).scrollTop(jQuery('#gforms_confirmation_message_3').offset().top);jQuery(document).trigger('gform_confirmation_loaded', [3]);window['gf_submitting_3'] = false;}, 50);}else{jQuery('#gform_3').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [3, current_page]);} );} );</script><script type='text/javascript'> if(typeof gf_global == 'undefined') var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"http:\/\/www.leoweekly.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"http:\/\/www.leoweekly.com\/wp-content\/plugins\/gravityforms\/images\/spinner.gif"};jQuery(document).bind('gform_post_render', function(event, formId, currentPage){if(formId == 3) {} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} );</script><script type='text/javascript'> jQuery(document).ready(function(){jQuery(document).trigger('gform_post_render', [3, 1]) } ); </script>
<small>* No spam, we promise. Unsubscribe any time.</small>
</div></div>
		</section>
<script type="text/template" class="trending-post-template">
    <ul class="trending-list">
    <% _.each( tp, function( trendingPost, i ){ %>
        <li><span class="count"><%- i+1 %></span> <a href="<%- trendingPost.url %>"><%- trendingPost.title %></a></li>
    <% }); %>
    </ul>
</script>
                </div>
            </aside><!-- /.sidebar -->
            </div><!-- /.content -->
</div><!-- /.wrap -->


<section class="masthead">
    <div class="container">
        <aside class="social">
            <h4>Follow Us</h4>
            <ul>
                <li><a href="https://www.facebook.com/theleoweekly" target="_blank"><i class="fa fa-facebook"></i></a></li>                <li><a href="https://www.twitter.com/leoweekly" target="_blank"><i class="fa fa-twitter"></i></a></li>                <li><a href="https://instagram.com/leoweekly" target="_blank"><i class="fa fa-instagram"></i></a></li>            </ul>
        </aside>
        <h1>Publishing Louisville's arts and entertainment news, community-focused stories, and colorful local commentary since 1990.</h1>
        <div class="officers">
                                                <span class="officer"><strong>Founder</strong> John Yarmuth</span>                                    <span class="officer break"><strong>Executive Editor</strong> Aaron Yarmuth</span> <br>                                    <span class="officer"><strong>Publisher</strong> Laura Snyder</span>                                    </div>
    </div>
</section>
<footer class="content-info" role="contentinfo">
  <div class="container">
    <div class="row">
      <div class="copyright col-md-6">
          <p>All material &copy;2017 LEO Weekly, Louisville, KY. All rights reserved.</p>
      </div>
      <div class="footer-nav col-md-6">
        <ul id="menu-footer-navigation" class="list-inline"><li class="menu-about"><a href="http://www.leoweekly.com/about/">About</a></li>
<li class="menu-jobs"><a href="http://www.leoweekly.com/jobs/">Jobs</a></li>
<li class="menu-contact"><a href="http://www.leoweekly.com/contact/">Contact</a></li>
<li class="menu-privacy"><a href="http://www.leoweekly.com/privacy/">Privacy</a></li>
<li class="menu-advertising"><a href="http://www.leoweekly.com/advertising/">Advertising</a></li>
</ul>      </div>
    </div>
  </div>
<!-- Quantcast Tag -->
<script>
 var ezt = ezt ||[];
 (function(){
   var elem = document.createElement('script');
   elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://pixel") + ".quantserve.com/aquant.js?a=p-a4LDpi_DEopn-";
   elem.async = true;
   elem.type = "text/javascript";
   var scpt = document.getElementsByTagName('script')[0];
   scpt.parentNode.insertBefore(elem,scpt);
 }());
 ezt.push({qacct: 'p-a4LDpi_DEopn-', uid: '' });
</script>
<noscript><img src="//pixel.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/></noscript>
<!-- End Quantcast Tag -->
<!-- Segment Pixel - LEO Weekly-Audience Extension - DO NOT MODIFY -->
<script src="https://secure.adnxs.com/seg?add=2794617&t=1" type="text/javascript"></script>
<!-- End of Segment Pixel -->
</footer>

<link rel='stylesheet' id='gforms_reset_css-css'  href='http://www.leoweekly.com/wp-content/plugins/gravityforms/css/formreset.min.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_formsmain_css-css'  href='http://www.leoweekly.com/wp-content/plugins/gravityforms/css/formsmain.min.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_ready_class_css-css'  href='http://www.leoweekly.com/wp-content/plugins/gravityforms/css/readyclass.min.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_browsers_css-css'  href='http://www.leoweekly.com/wp-content/plugins/gravityforms/css/browsers.min.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='gravityformsmailchimp_form_settings-css'  href='http://www.leoweekly.com/wp-content/plugins/gravityformsmailchimp/css/form_settings.css?ver=4.1' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/www.leoweekly.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.leoweekly.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='http://www.leoweekly.com/wp-content/themes/leo/assets/js/vendor/modernizr.min.js'></script>
<script type='text/javascript' src='http://www.leoweekly.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='http://www.leoweekly.com/wp-content/themes/leo/assets/js/scripts.min.js?50dd47db8c140404bb4de3fbf616af00'></script>
<script type='text/javascript' src='http://www.leoweekly.com/wp-includes/js/wp-embed.min.js?ver=4.6.3'></script>
<script type='text/javascript' src='http://www.leoweekly.com/wp-content/plugins/gravityforms/js/jquery.json.min.js?ver=2.1.1'></script>
<script type='text/javascript' src='http://www.leoweekly.com/wp-content/plugins/gravityforms/js/gravityforms.min.js?ver=2.1.1'></script>
<script>
        (function(b,o,i,l,e,r){b.GoogleAnalyticsObject=l;b[l]||(b[l]=
        function(){(b[l].q=b[l].q||[]).push(arguments)});b[l].l=+new Date;
    e=o.createElement(i);r=o.getElementsByTagName(i)[0];
    e.src='//www.google-analytics.com/analytics.js';
    r.parentNode.insertBefore(e,r)}(window,document,'script','ga'));
ga('create','UA-61396929-1','auto');ga('send','pageview');
</script>

<!-- AdRotate JS -->
<script type="text/javascript">
</script>
<!-- /AdRotate JS -->


</body>
</html>
